I’m getting the following error on my discord bot, kakuhou-surgeon. I’ve been receiving it periodically for the past few days. The errors usually come in streams, so it spams console all at once, but not all the time. It occurs on-and-off. I don’t know what it means and I don’t know how to fix it. The project is private, so if you are able to help me, please reply to this thread and I can invite you to the project.

ERROR Unhandled rejection: Error: connect ETIMEDOUT

11:02 AM

at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1191:14)

Does your bot stay offline when that error shows up?

As far as I’m aware, the bot has stayed online. When the error stops appearing, no ready event is triggered; the bot just periodically stops functioning and this error shows up in console. Also, I don’t know if this happens every time the error occurs, but when I saw it this morning the project’s memory capacity was almost full and then it emptied out after the error stopped appearing.

Do you know any code that might of done this?

No, I’m not exactly sure where the rejection is coming from.

Can anyone help me figure this out?

I’ve been trying to do more research but I can’t find anything helpful. I’ve tried remixing the project but got the same error. I have no idea what’s causing it.

Do you have that is relevant with your webpage?

What do you mean? The project is a Discord bot, so the webpages of the project shouldn’t be causing the error, seeing that they are very minimalistic.

Like a dashboard. I thought that may be an error causing webpage.

Anyway, can you try to create a new project, (you can remix this one if you want) and transfer your codes&files to that new project?

I already tried remixing the project and the same error occurred. It says the error is coming from a file called ‘net.js’ but when I run find . -name net.js in console, it doesn’t return any results.

I didn’t said “Remix your own project”. Can you please type ls to console pelase?

It just gives me a list of all of my files. Nothing called “net.js” though. I’ll try creating a new project and transferring the files.

Alright, the new project seems to be working now. I’ll let you know if the error starts up again. Thank you for the help!