"Export Successful" but nothing on Github

I need to clear up space on my project and I don’t want to mess with the files on Glitch directly. I try exporting to Github and Glitch says the export was successful but no commits on my Repo. I’ve already tried revoking and adding Github access back to Glitch as well as making my repo public.

Hey Ryan, I think I saw a question from you over Facebook as well, and thought I’d sent a reply but it looks like it didn’t make it through. My apologies!

When you export from Glitch to GitHub you won’t see a pull request automatically generated. Glitch will push to a glitch branch in your repo (creating it if it doesn’t exist). You would then have to use the GitHub interface or some other means to create a PR to be merged into your master branch. We indicate this in the export dialog:


but it’s kind of subtle.

Sorry for the bother!

I’ve been looking there as well but nothing.

I see. That’s not expected behavior. Can you let me know the project name you’re working on so I can take a look at our logs?

Just a heads up that I had the same issue around a month ago when trying to export a project with multiple files to github.

Should be puck-bot. Thanks for the help

Hey Ryan, the problem here was that because you’d run out of space your most recent set of changes couldn’t be committed to your project’s backing repo. Since your repo was in an uncommitted state our service couldn’t complete it’s job, unfortunately telling you everything was ok in the process.

I temporarily expanded your project’s disk space, which allowed it to commit the recent changes on its next Checkpoint. If you try to export again you should have better results.

Sorry for the bother!

Thanks! Worked like a charm! Will there be any future upgrades to disk space?

We’ll have paid plans sometime in the future, but we don’t know exactly what those will look like yet; additional disk space may be an option.