Feature idea: Alert user when syntax error is caused by old node version

Working from a project template (via FCC), and I assumed I was doing something dumb when I got an error saying “Unexpected token: ‘…’”. Eventually I realized it was using an old version of node (6.9.1, pre-spread-operator) and that I have the ability to control that. But, it would be neat if there could be some kind of alert for such an occasion.