"Fetching Project..." forever. "WebSocket connection" errors


#1

I just tried starting a new project, and it has been showing this for the past 10 minutes:

image

In Chrome DevTools:

Warning: WebSocket connection to 'wss://api.glitch.com/stupendous-turn/ot?authorization=ca678352-98aa-9811-73da-75110cbdabef' failed: WebSocket is closed before the connection is established (reconnecting-websocket.js:231)

Error: WebSocket connection to 'wss://api.glitch.com/stupendous-turn/ot?authorization=ca678352-98aa-9811-73da-75110cbdabef' failed: Error during WebSocket handshake: Unexpected response code: 502 (reconnecting-websocket.js:231)

(Note that I edited the authorization parameter in case that’s meant to be secret.)

I tried to open it in an incognito tab and in Firefox, but the same problem occurs. Since it’s a 502, it seems like this might be a problem with Glitch’s servers, rather than with something I’ve done - but I have no idea, really.

Edit: Ah, looks like it is a glitch.com problem. Others have reported it too:


#2

Sorry about, we had an outage earlier which we’re recovering from (https://status.glitch.com/). Let us know if problems persist with your project.


#3

I think this is fixed now. Let us know if you see any more problems.