Few bugs I have found

https://gyazo.com/1eb03b40595a231f06bbea59c8f9fe63

Where the “warn/error” for container stats is shown, it seems to be out of place, and when it is not there, the tools button is bigger than it should be, as if it a warn/error was there.

https://gyazo.com/4f1dada2ae612d16587de2a9875fc24d
https://gyazo.com/c7b4761094aa0013a1992d2aa8a92915

Running on the latest stable version of chrome on windows 10

Another bug I found, is that my icon on the rewind timeline is higher than it should be, I never seen it like this before
https://gyazo.com/8bbdc639696cdeee1da8ca244916cf43

Once again another bug:
https://gyazo.com/a490990cc914074de23c5e819c271ab3
To produce that I just dragged the slider past the zero.

Another problem I experienced earlier with rewind, is when I rewinded a project, then click on the icon where it shows it was rewinded in the timeline, then try to glitch anywhere else, it would not work and go back to where it was and not let me do anything.

https://gyazo.com/7ec710cfbc51b3df06739b5c1c6e41e7

A bug I experienced yesterday, was when I tried importing from a GitHub project, and it said the “arghh something went wrong error” even though when I refreshed from the console and the editor page, it had imported just find
I also tried cloning from the project and then used the refresh from the console, and it said, restarted, and I went to the editor it showed the “connected” message, but did not refresh at all, and I have to refresh the editor page completely to see new changes made from the console

@Callum-OKane Do you know if this is something I can remix to look into? I found the “community” app on glitch, but not the Glitch coding interface itself. <-- EDIT: Never mind, found it!

1 Like


:point_up: Just in case anyone else comes along with the same question I had – took me a minute to realize that while I could run the code editor through a remixed community site, I can’t actually modify it.

Since I already did a little poking around before I realized that, I’m sharing it below in the hopes that it helps!

The “warn/error” badge errors that are mentioned above seem to be happening for the following reasons:

Those badges contain text, but are being assigned the icon class alongside the status-badge class. The icon class has a fixed height and width meant to contain the element, so the badge itself is breaking out of those size constraints and positioning itself incorrectly. Removing the extra class seems to fix it!
before:
status-badge--before

after:
status-badge--after

As regards the tools button, there are two divs, each containing status-badges, as siblings to the span containing the text “Tools”. The first div has the class “hidden,” and therefore isn’t visible – the second one is not hidden. If you add “hidden” to the second div containing status-badges, it seems to resolve itself.

before:
tools-button--before

after:
tools-button--after

2 Likes

I have just found another issue, when I went to view the users who voted on this suggestion:
https://support.glitch.com/t/custom-loading-screen-on-glitch-projects/5096

https://gyazo.com/bbdee3df2561bf8075b77105bc62895b

That’s a bug with Discourse itself. I’d suggest you report that on the Discourse forums.

1 Like