Files missing in editor

As of yesterday the editor doesn’t seem to show all of my project’s files in the frontend section. Everything seems to work correctly when running the project, and templates that aren’t showing up in the editor are correctly rendered. When I download the project, all the files are present. Any ideas on what’s going on?

Projects only show up to 100 files, so if you have many files that may be the cause. We’re going to update the UI to handle many files more elegantly than just hiding them, but for now you can .gitignore to temporarily remove files from the UI while you edit the others.

My project only has about 12 files in it though, unless it’s somehow counting installed node modules?

no, it doesn’t count such files, so it’s not that then. Let me know your project name and I can take a look for you.

The project’s name is private-september.

I get an error saying there’s no project with that name or it’s private - if it’s private can you DM me a join link - thanks.

It’s indeed private. This might be silly, but I can’t figure out how to send DMs. I see the message I received on account creation by the system account, but nowhere where I could create a new message to anyone.

I’ve sent you message so you can reply to that

Thanks - I’ve taken a look and there doesn’t seem to be any good reason for them to not be showing up. I’ve raised a bug with the developers and they’ll take a look ASAP. Sorry for the problems.

1 Like

Hi Julien,

we fixed your issue: it was due to invalid characters in the files, that tricked the backend into thinking they were binary files… we opened a bug report to fix this issue in the future, but for now, all of your files should be there :slight_smile:

Thanks for reporting, and happy Gomixing :slight_smile:

3 Likes

Thank you!

Regarding the invalid characters, yesterday while working on the project the editor started misbehaving slightly. The cursor was sometimes seemingly offset by 1 character. I can’t remember copy-pasting anything into the page except for some URLs. Note that the editing was done on Windows using a French keyboard layout. (I know I’ve had trouble with contenteditable areas with compose keys and illegal characters in the past …)

Thanks for the feedback!

We are going to replace major parts of the editor in the next few days, so perhaps your problems will go away :slight_smile: keep up posted if anything weird happens :slight_smile:

Hi, I think i’m having a similar issue. could this still be a problem 3 years later?
some css files (in public/css/ )
disappeared since logging in a day later.
the live site still seems to return them/host them so they’re there, just not visible.
the project is flex-collabplaybook if you can take a look
update: exporting to github interestingly did not help. they’re not showing up there

Hey @madmaxlax,

Can you open the terminal and run ls and see if the file exists among the list of files printed?

2 Likes

ooh nice,
yep they’re there for an ls command!

2 Likes

I suspect the files got gitignored…

  1. Create a .gitignore file if one does not exist.

  2. Add the following content to .gitignore:

!public/css/
  1. Open the terminal and run refresh.

Let me know if this doesn’t work!

2 Likes

uhhhg they did indeed get git-ignored, i wonder how that happened

thank you!!

3 Likes