[Fixed] Clone From Repo - An Error Occured


#1

No clue on why?
How do I figure this out?

Trying to clone this


#2

I can reproduce this error. It’s not clear to me why it would fail either, so I’ll flag it to our development team and we can get the cause resolved.

In the mean time, try the separate Import from GitHub option available from Advanced Options from the top-left project info menu in the editor. This uses a different method to copy a project.


#3

Thanks
One guess - Could it be the assets folder?
Seems like those are not really handled like a normal folder on your site


#4

Import also fails
Arg, something went wrong. Try again?

Note: I am just trying out your site, so tell your development team this is very low priority


#5

It shouldn’t be that. You’re right that the assets folder on Glitch isn’t a normal folder, but what should happen is the assets folder in the GitHub project would be copied across but the files wouldn’t show in the editor (because no binary files do). You’d still be able to access them in code and see them in the console. So that shouldn’t be the cause.

But thanks for the info on the import option. I’ll add that to the case and I’ll see what our dev team come back with.


#6

Interestingly, I was able to import when trying the ‘Import from GitHub’ option (it works differently in that you just enter the org and repo name e.g. ng-chicago/AddToHomeScreen_Dist, maybe that was the problem?) so feel free to remix https://glitch.com/edit/#!/regular-caraway if you want to work with that project code.


#7

A fix for this issue has now been deployed! (you’ll need to refresh your editor to pick up the changes)


#8

Works beautifully, Thanks!

One more question
If I change the contents in GitHub, will it automatically pull those changes?
If not, is there an easy way to reload from GitHub?


#9

No, we don’t support syncing with GitHub yet (it’s possible with GitLab though). It’s something we plan to add in the future. For now, if you use the ‘Import from GitHub’ button I mentioned yesterday, that overwrites the current project with the contents of the project on GitHub. Or, since you’ve used the clone-from-repo ready, you can git pull from the command line.


#10

I just tried
Advanced Options - Import from GitHub
Into the existing project

And got “Something went wrong” message in upper right

So that may need some looking into
But not a high priority

I’ll look into GitLab - Thanks


#11

It’s working for me. When trying that option, be sure to just enter the org and repo name e.g. ng-chicago/AddToHomeScreen_Dist rather than the full git URL. But perhaps the git pull option I added above might be more useful to you.


#12

Tried with this
ng-chicago/AddToHomeScreen_Dist.git

arg, something went wrong


#13

Just the org name and repo name, no .git e.g. ng-chicago/AddToHomeScreen_Dist