Fixed: Console (bottom pane and full page) not working in Chrome

Getting the error message below in the JS console in Chrome when I open the console in a project. I am able to use the console in Firefox. The black background appears, but the cursor doesn’t appear. Just wanted to share here in case someone else is hitting the same issue and looking for a fix.

Terminal.ts:369 Uncaught Error: No option with key "paddingBottom"
    at Terminal../node_modules/xterm/lib/Terminal.js.Terminal.setOption (Terminal.ts:369)
    at Terminal../node_modules/xterm/lib/public/Terminal.js.Terminal.setOption (Terminal.ts:146)
    at index.ts:34
    at Array.forEach (<anonymous>)
    at Socket.<anonymous> (index.ts:32)
    at Socket../node_modules/component-emitter/index.js.Emitter.emit (index.js:133)
    at Socket../node_modules/ (socket.js:138)
    at Socket../node_modules/ (socket.js:335)
    at Socket../node_modules/ (socket.js:232)
    at Manager.<anonymous> (index.js:21)

Hey @PatrickWeaver I’m unable to reproduce this issue with either the Logs Pane’s console or the full-page console. We sometimes see different results from different geographical areas due to edge caching issues, so I’ll keep an eye out for it, but if there’s any additional information you can share that would be great! Do you see this on multiple projects? What OS are you on? Do you see it in both consoles or just one or the other?

Thanks, and sorry for the bother!

No problem, I saw this on the 2 projects I looked at, macOS Chrome 76. Still getting it now on a new project I just created:!/gravel-lark?

Same behavior and same error in bottom pane console and full page console.

Thanks for the additional info! I still can’t repro, but will keep looking.

Oh! One other thing - do you see this in a private window with no extensions?

Console works in an incognito window, both signed in to Glitch and not.

Tried disabling all Chrome extensions but I got the same behavior in the regular window.

I’m not able to reproduce on any other computers, very weird, thanks @cori for looking into it!

I reinstalled chrome and now it’s working.

1 Like

That’s super strange, @PatrickWeaver, I’m glad you found some sort of resolution!