[Fixed] No space for node modules


#1

Started getting this error in project “sonicbot”

npm WARN tar ENOSPC: no space left on device, write

4:32 PM

npm ERR! cb() never called!

4:32 PM

4:32 PM

npm ERR! This is an error with npm itself. Please report this error at:

4:32 PM

npm ERR! <https://npm.community>

4:32 PM

4:32 PM

npm ERR! A complete log of this run can be found in:

4:32 PM

npm ERR! /tmp/npm-cache/10.15.0/_logs/2019-02-08T15_32_38_576Z-debug.log


#2

I fixed it by using:

rm -rf node-modules
rm -rf .git
:grinning:


#3

Hi there! Glad you got it working. Another great thing to try now that you have a bit more space is to make sure you’re actually using pnpm - you can run enable pnpm just in case. If you do that, Glitch does some magic and doesn’t count your node-modules against your space quota. :slight_smile:


#4

I already know for that, pnpm actually is enabled but it automatically stopped working, idk how but yeah now it’s working and it’s not installing it in my project