[Fixed] Wont Install Dependencies

idk wat happened but its fixed… {The Dependencies wont install, i tried adding them manually thru package.json but it still wont work. i even tried doing it thru the console but still nope.i even tried remixing the project. pls help}

Can you give us some more details? What is going on when you try to install dependencies over the terminal?

Make sure you are typing it correctly, it should look like this:

  "dependencies": {
    "discord.js": "^12.4.1",
    "example":"^1.0.0"
}

You know you can always run this in the terminal

npm i package_name --save

And use it like

npm i discord.js --save

and then run

refresh

when your done

1 Like

My Terminal wont open up

its the exact format {

“//1”: “describes your app and its dependencies”,

“//2”: “https://docs.npmjs.com/files/package.json”,

“//3”: “updating this file will download and update your packages”,

“name”: “hello-express”,

“version”: “0.0.1”,

“description”: “A simple Node app built on Express, instantly up and running.”,

“main”: “index.js”,

“scripts”: {

"start": "node index.js"

},

“dependencies”: {

"anime-scraper": "^3.1.1",

"ascii-table": "^0.0.9",

"canvas-senpai": "^0.1.6",

"common-tags": "^1.8.0",

"discord.js": "^12.1.1",

"moment": "^2.27.0",

"node-fetch": "^2.6.0",

"quick.db": "^7.1.1",

"something-random-on-discord": "^0.0.1",

"weather-js": "^2.0.0",

"prompt": "^1.0.0",

"discordjs-prompter": "^2.0.3",

"snekfetch": "^4.0.4",

"axios": "^0.21.0",

"no-api-key": "^1.0.0",

"figlet": "^1.5.0",

"util": "^0.12.3",

"discord.js-menu": "^2.1.1",

"request": "^2.88.2",

"request-promise-native": "^1.0.9",

"youtube-search": "^1.1.4",

"canvacord": "^5.0.8",

"mathjs": "^7.5.1",

"discord-emoji-convert": "^1.6.0",

"express": "^4.17.1",

"http": "^0.0.0"

},

“engines”: {

"node": "12.x"

},

“repository”: {

"url": "https://glitch.com/edit/#!/hello-express"

},

“license”: “MIT”,

“keywords”: [

"node",

"glitch",

"express",

"discord",

"discord-bot",

"discord.js",

"discord-chat",

"discord-chatbot",

"chat",

"chatbot",

"tutorial",

"javascript"

]

}` this is the package.json file… i know there lots of dependencies but i tried decreasing and adding them one by one but still it wont install

the problem is the terminal wont load up
it shows “Failed to start terminal”…

You should contact support@glitch.com in that case.

2 Likes