Flask Pyrebase -- installing Pyrebase breaks flask and then my app does not run

#1

I know that Flask is not officially supported but I am having an issue where my students want to use the pyrebase wrapper for accessing Firebase from python in an Flask app. I the code runs fine in Mac Terminal but when I try to do the install on Glitch the Pyrebase breaks flask. Here is a demo of what is happening.

#2

Hey @gbenedisgrab, welcome to the Glitch forum! Sorry for the bother!

When you’re running this locally, I’m curious what version of pip you’re running, and if you can repro the error you’re encountering if you use the same version of pip that Glitch is on (v18.1, I believe).

#3

Thanks cori. I will try to reproduce the issue in terminal by downgrading. I am running python 3.7 and pip 19. I would really love to use them together on Glitch if possible.

#4

Here is something I found about an error I am seeing
You have an out of date version of setuptools , sorry for the inconvenience (and hard to understand error).

Simply pip install --upgrade setuptools

Can I upgrade setuptools from .requirements.txt?

#5

Hey @gbenedisgrab, first off I must stress that I am not a pythonista, so take anything I say here with much skepticism.

I was able to specify an updated version of setuptools by adding setuptools>=40.0.0 in .requirements.txt. It seems like Python tried to do as I asked because when I did that and removed Pyrebase from the requirements I got an error telling me tensorflow 1.10.1 has requirement setuptools<=39.1.0, but you'll have setuptools 41.0.1 which is incompatible. That error went away if I specified setuptools>=38.0.0,<=39.1.0 but that didn’t seem to resolve the issue with Pyrebase.

We have work underway to update some of the project containers installed software, and I’ll pass this along to see if we can include updated versions of python and pip, but I don’t know when that will land, so I don’t have a timeline for you. I’m sorry for the bother!