Getting gRPC error all of a sudden


#1

my system has been running for weeks in test mode, nothing was updated and all of a sudden im getting this error on my glitch console.,

this is the error in the console.

(node:7036) UnhandledPromiseRejectionWarning: Error: Failed to load gRPC binary module because it was not installed for the current system
Expected directory: node-v64-linux-x64-glibc
Found: [node-v57-linux-x64-glibc]
This problem can often be fixed by running "npm rebuild" on the current system

Original error: Cannot find module '/rbd/pnpm-volume/2df7ac48-e8a5-4fd0-b553-50c11b74f660/node_modules/.registry.npmjs.org/grpc/1.15.1/node_modules/grpc/src/node/extension_binary/node-v64-linux-x64-glibc/grpc_node.node'
at Object.<anonymous> (/rbd/pnpm-volume/2df7ac48-e8a5-4fd0-b553-50c11b74f660/node_modules/.registry.npmjs.org/grpc/1.15.1/node_modules/grpc/src/grpc_extension.js:53:17)
at Module._compile (internal/modules/cjs/loader.js:688:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:699:10)
at Module.load (internal/modules/cjs/loader.js:598:32)
at tryModuleLoad (internal/modules/cjs/loader.js:537:12)
at Function.Module._load (internal/modules/cjs/loader.js:529:3)
at Module.require (internal/modules/cjs/loader.js:636:17)
at require (internal/modules/cjs/helpers.js:20:18)
at Object.<anonymous> (/rbd/pnpm-volume/2df7ac48-e8a5-4fd0-b553-50c11b74f660/node_modules/.registry.npmjs.org/grpc/1.15.1/node_modules/grpc/src/client_interceptors.js:145:12)
at Module._compile (internal/modules/cjs/loader.js:688:30)

(node:7036) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)

MOD EDIT: formatting


#2

Hey @killerbswarm our apologies for the inconvenience!

This was probably due to a recent deploy on our side which updated the default node version and our install script isn’t checking for the change. If you explicitly set the node version in your package.json file you should be all set.

If you’d like us to take a look please provide your project name (if you’re worried about keeping it private you can email to support@glitch.com).


#3

sent an email, thanks!


#4

Received, and I updated your package.json to downgrade the node version back to version 8.x by adding

"engines": {
  "node": "8.x"
}

to the end.

Once again sorry for the inconvenience and let us know if you run into any other problems.

Happy Glitching!


#5

Thanks. It’s working now