Ghost blog can't upload images. Possible Sharp module issue?

Hello there!

Very new to glitch and a little stuck.

I’m trying to set up a Ghost blog by remixing https://glitch.com/~ghost at https://glitch.com/~paceandfizzle.

The blogging features seem to work fine however trying to change or upload any images fails to work. The Ghost settings gives “Ghost is down for maintenance etc…”

Going back to glitch the log debugger shows many warnings like

[2019-08-22 02:50:09] WARN Cookie members-ssr not found

And specifically when trying to add images shows

Something went wrong installing the "sharp" module

Cannot find module '../build/Release/sharp.node'

- Remove the "node_modules/sharp" directory, run "npm install" and look for errors

- Consult the installation documentation at https://sharp.pixelplumbing.com/en/stable/install/

- Search for this error at https://github.com/lovell/sharp/issues

This is something you should probably try to ask in Ghost Project website/github, not here. Glitch cannot offer assistance on third party modules.

hi @paceandfizzle - i’m sorry you had this issue, it appears to be happening on all remixes of ~ghost, probably because of a version update!! i’m working on finding out how to fix or if there’s another app running ghost that works and will post here when i do!

2 Likes

Also experiencing this. Been trying to fix it for a while now. I’ve installed and tried to reinstall Sharp a number of times

1 Like

hey i’m back @paceandfizzle, @robocopkaka - so i got a remix of ~ghost working by doing a few things: updating the ghost package in package.json, changing the node version in the same file to 10.x since ghost only supports 8 and 10 LTE versions, and then i ran enable-npm in the console because i believe the version of pnpm we are using is not compatible with properly building the sharp package.

getting pnpm updated is something the platform team is working on and can take some time. in the meantime, if you remix https://glitch.com/edit/#!/evergreen-sassafras - it should have working image uploads. let me know if it does/doesn’t work out for y’all! if so, i’m going to make that the canonical ghost app for folks to remix off of.

thanks for your patience btw!!

2 Likes

I remixed the second project and I don’t have image upload errors. Thanks a lot.

3 Likes

awesome, so glad to hear!! it may take me some time but i’m going to make sure that app i made that works gets renamed to ~ghost so that no one else runs into this problem!!

1 Like