Ghost project runs out of space with node modules


#1

Hey there! I have a project at adjoining-tarp.glitch.me, it’s a Ghost blog that has been running since the summer with no problems. Early this morning it crashed (seemingly out of nowhere), when I checked it out, it keeps running out of disk space by a lot. If I remove all of the node_modules, it uses only 17MB. Once it starts installing from npm, it quickly passes the disk limit.

I read that I could use pnpm by typing enable-pnpm so that node_modules wouldn’t count towards the disk limit. I did that and they still are getting installed the same way. Do you have any solutions to this?

And thank you! Glitch is amazing, I have learned so much in programming and web development, it really is an awesome resource.


#2

I ran into this issue the other day myself and as a quick fix the easiest thing to do is restore it to an earlier backup. Have you added any new content to it in the last few days or am I ok to restore? We’ll look into the underlying cause. And glad to hear you’re liking the service!


#3

Hey Gareth, thanks for the response. I was able to get pnpm working by running pnpm install, which solves the low disk storage issue. But the start script for the Ghost project uses bash init.sh && node node_modules/ghost/index. How would I reference the the index file from the ghost package now that I’m using pnpm? I know npm puts everything into the node_modules folder, but where does it go with pnpm?

And it hasn’t been edited or modified in a long time, so I’m not sure why it doesn’t work now. The earliest possible backup was 7 months ago, but I’ve edited it since then using the Ghost UI. Even when I tried that backup, I still ran into the same issues. Thanks!


#4

pnpm still saves packages in the node_modules folder/directory. You should be able to run cd node_modules && ls in the console to list all packages in the node_modules directory.


#5

Thanks for the tip. The problem now is that pnpm never actually got enabled. Because the project keeps erroring out, it keeps reinstalling the modules from npm. So when I enter enable-pnpm && pnpm install in the terminal, the terminal installs the modules from pnpm while the editor is also installing them using npm.

Is there a way I can do a hard switch to pnpm, or stop the editor from installing using npm so I can switch to pnpm? Thanks


#6

Finally got pnpm working, but the Ghost version I was using was so old. Tried updating stuff but never got it working. Gave up and remixed the new https://glitch.com/~ghost project. Luckily I had a json backup from Ghost from only a few weeks ago. So it’s working now.

The ~ghost project on Glitch that is remixable is in development mode, not production, so it logged literally every single request for 6 months or so into a .log file, which is now 150mb+. I think that was what initially stopped the project.