Git clone error

I’ve always getting error

Invalid Content-Type: application/x-git-upload-pack-advertisement

whenever i tried Git cloning from Glitch using as the URL

Hey @FrostingBit, I’m not seeing this error when I clone one of my projects, so the problem you’re seeing may be project-specific; can you share your project name?

My project name is ‘accessible-witch’ where the git url are, i don’t think the error is project-specific because it happens to all of my projects or it’s only my git client?

I’m able to clone that project without any difficulty. What’s the client you’re using? We had seen a problem like this with Working Copy a while back, but I thought it had been resolved.

I tried it with some Git client for my Android because I would planning to work remotely.
Edit: I’d get it to work with Termux but sometimes using command line aren’t so effective

If I recall correctly there’s not a convenient fix for this on our end because the library that we’re using for git operations sets the content type for those operations. The author of Working Copy ended up modifying their client not to reject those calls based on content type (again I’m speaking from memory).

You might be able to contact whoever wrote the git client you were using to see if they could make a similar change. I’d be interested to know what client it is to test it myself.

Okay, thanks for your such explanation! Sadly, there is almost no Git client for Android devices (even though you get it, most of it are outdated)

Some of the clients that I tried: MGit, Green Git Client,