GitHub connection not working

Whenever I try to sign in with my GitHub, it gives me this error:

I’ve been doing this for days and it doesn’t work. What could be wrong?

1 Like

What’s your GitHub login?

Username: gurpreetsinghmatharoo

Sorry, it looks like we have a bug in how we report that error. The problem is that you logged in with facebook the first time, and your email address is tied to that account. For now, you can use your facebook login, and we’ll look into fixing this.

  1. My Facebook account uses the same email address

  2. I want to use GitHub for the import/export feature

I know I could just download the app files and create a repository myself, but I would still like this feature to work, because why not?

Thanks for your help.

Have you tried going to the import/export and granting GH permissions there instead of logging in with GH? I’m not clear whether you were getting the error logging in or trying that. Off the top of my head, I’m not sure whether or not that will work for you.

That’s what I was doing.

Hi @gurpreetsinghmatharo,

sorry for the long wait! Are you still experiencing this issue? Would you mind try to log in again now? Let us know when you do it and if you get the error again, I’ll investigate :slight_smile:

Yep, still the same.

Thanks for helping out!

Unfortunately we didn’t see any error coming on our end: can you check in the WebConsole for errors and send a screenshot?

Here’s what shows up after I click on “Add your GitHub account”:

can you try this experiment? What happens if you log out, and then try to login with Github? Still the same issue?

That worked, thanks!

I faced a weird bug, though. The moment I logged out, it would just log me back in again, in a second, without any prompts. I use Chrome, so I opened up Firefox and logged in using GitHub from there. Authorized it, and it works now, even on Chrome.

A post was split to a new topic: Can’t log into GitHub to export