Github export failing


#1

I wonder whats happening around with github export lately.

I was exporting codes from glitch into private repo of mine over github.
It was working fine around 2 months back.
I tried to export it back to the same repo, but it didnt work.

Actually it stated succesfullly exported but I cant see the codes over in github.
I tried revoking github access, and even github warned me for multiple actions with 3rdParty.
so I then had to even reverify the ouath.

But still no luck.

I would love to have it sorted.


#2

Hi Froosty :slight_smile:

May I know your username on Glitch? I’d like to verify if your GitHub token is still valid.


#3

Hey @etamponi, i am having the same issue of not exporting. Also tried to remove branch on github with no luck.

Glitch repo: hadesbotty-testy (user Favetti)

thanks


#4

Just tried to revoke access, logout, login and grant access. Still says export sucessfull but nothing new on github.


#5

Are you exporting to an organization repo? If so, be sure to add 3rd party approval for Glitch: https://glitch.com/faq#github


#6

@Gareth I am not (github: Favetti/hadesbotty)


#7

Its the same name from here, i.e. Froosty.
and yeah to clarify I am not trying to export to organization.


#8

@Froosty, @Favetti,

would you mind if I impersonate you on Glitch and try to export to your projects? So that I can try to figure out what’s going on.

@Froosty, if you accept, what’s the repo which you’re trying to export to?


#9

@etamponi, sure, no problem.


#10

@Favetti,

did you export 2 hours ago to https://github.com/Favetti/hadesbotty? I see a commit 2 hours ago in the Glitch branch: https://github.com/Favetti/hadesbotty/tree/Glitch


#11

@etamponi i just created some trash file directly on github, creating a new branch called Glitch - trying to understand the problem.


#12

@Favetti this is the error:

Exporting to Favetti/hadesbotty stderr: fatal: Couldn't find remote ref master

We expect the GitHub repository to have a master branch. You named it Master. I think that if you create even an empty branch named master, it will work.


#13

Yeah I am completely fine with it.
And yeah the repo I am trying to export to is a private repo, and its
https://github.com/TheLearneer/gearz


#14

@Froosty, does your repo have a master branch (exact spelling and capitalization)?


#15

here this is the context.


#16

I hope you saw the screenshot I sent and maybe are trying to figure out the issue ??


#17

yes, I am checking :slight_smile: thanks


#18

I was just curious as its pretty much night time over here, so I might head off for bed, and wont be able to reply to your queries sooner.
And I hope it would be fixed soon.

I am not in extreme need of it, but its something I would prefer over downloading the repository and manually uploading to GitHub.

And yeah as always you guys are awesome with your service :smiley:


#19

@etamponi Ok, i created a master branch instead of Master and its working again.

Thank you for your help!


#20

Hey guys, export is broken again…

Now it is creating empty commits: