Github import fails


#1

Hi.

Just tried to import from github repo.

Result:
Arg, something went wrong. Try again? :@ :woman_facepalming:

Would be great to get a more bit more helpful information about it.

There also is no output in the log

The browser console shows
Promise rejected (async)
importFromGitHub @ project-import-export.coffee:30
importFromGitHub @ advanced-options-pop.coffee:36


#2

Hi,

I experienced similar results. In my haste, I pasted the full GitHub .git address of the repo before I saw that the input on the prompt said, “user/repo”. 37 PM.

I tried pasting the repo address, the https clone address, the ssh clone address…

It was only when I completely reloaded the page in another browser (and slowed my roll), that I saw that the prompt loaded by saying “user/repo”.

#LessonLearned, just type in your GitHub username/repoName.
#MaybeYourIssueIsDifferent
#HaveAGoodDay


#3

Hah, sorry about that. There’s plenty we can do to improve that flow for sure.


#4

orgname/repo also works. Woot!


#5

I may have worded the problem I wanted to raise in a hard to understand way, but I didn’t write the git import doesn’t work at all. What I wanted to say is that the situation when the import fails could be improved. So I’m not sure what these comments try to accomplish.

The situation is even so, that the content is deleted even when the import fails.