Glitch bugged need help

Have you installed the discord.js package?

cant install


Instructions on how to install an npm package on Glitch without using the terminal:

Yes I had the same issue yesterday, it’s linked to the recent Glitch issues. I’m using discord.js and sometimes it’s not recognized in the package.json.

I tried enable-pnpm, it worked after multiple attempts and a bit of luck.

This isn’t a glitch issue. This is a package issue. Add discord.js to your package file

Yesterday it took forever to load the discord.js package. When it doesn’t load successfully it runs the app without it.

There was 2 types of loading issues yesterday :

  • One where it stayed as “installing”
  • One where it launched without packages

On the 2nd type it sends an error about the module loading error in loader.js (which is where modules are loaded), then an other error at the position where the module is required.

Can try with enable-pnpm, or npm rebuild?

This isn’t a fix for this at the moment @SebPautot, see this: