Glitch Debug command does not work

System: Latest version of vscode 1.36.1 on Windows 10 64-bit and Glitch extension 0.1.0

Ran Glitch Create project to create an express project
Modified the server.js to the following:

app.get('/', function(request, response) {
  response.sendFile(__dirname + '/views/index.html');

Places a breakpoint on the console.log line and ran command Glitch: Debug
vscode enters debug mode, the Glitch log command says Debugger attached.
If I run Glitch show app in browser the page loads and the output log prints “hi” but the breakpoint is not hit

I thought it might be because I have node 10.14.1 installed locally. I tried updating package.json to have:

  "engines": {
    "node": "10.x"

It looks like the glitch app restarted after that but debugging still does not work. Also using the Glitch terminal command and running node -v still shows v8.15.1. I did not trying downgrading my local node.js install to v8.

Thanks for reporting this.

It looks like breakpoints aren’t working on Windows but the debugger itself is. If you replace the console.log with debugger I think it will interrupt there as expected. Let me know if not.

Breakpoints are better though, we’ll work on getting those fixed.


The debugger statement worked great! Was able to inspect variable values and use the debug console from the debugger point.

1 Like