Glitch giving errors at places that doesn't give any error

#1

So, working on a command. Then I run it and I get the error “Response2.content is not a function” where the code was just let umReason = Response2.content

I was confused about it, and even the Discord.js moderators said that it’s a false error. It says I am trying to call a function, but in the code, I am not.
This has even happened before.
It works at one place in the code, then I got something identical and it doesn’t work, it thinks I am trying to call a function, when the code isn’t.
What is going on?

How am I defining this as a function..?
#2

i am having the same thing, plus, when i place down a `, ', or ", it does not appear

#3

Hi @zApexio can you provide either the code in question, or better yet your project name so someone can take a look?

@Jonyk56, same question for you, and additionally I’m not sure what you mean with the other information about things not appearing. Can you help me understand that with some details?

#4

Refresh and try again. The site bugs out from time to time.

#5

The project name is the same as always, xnegnolust.
And I just apparently managed to fix it by putting a ; at the end of the part I provided, the part where it thinks it’s a function. This is weird. Especially since I even tried the old code in a normal file on my own computer and it worked in there.

Time for me to get back to my date with JavaScript <- Community meme “Apex’s girlfriend is JavaScript”

#6

Hey @zApexio I can’t find that project, so I can’t look any more deeply without additional information.

#7

Oh I just realized. The project name is xnegnolustbot not xnegnolust. Sorry about that.