Glitch is adding phantom characters to my project and removing others


Whenever I make an edit to my project, it will error saying that a character that isn’t even in the editor is causing the problem. Sometimes, it will even remove my commas in a list. I’m extremely confused.

first is error, second is actual

It’s also showing the wrong line number in the output so I have no idea where the actual error is.


Hi @pancake,

it looks like your editor for some reason went out of sync with what is present in the filesystem. This typically happens if you edit a file from the console, or if a process modifies your files. Right now we don’t support editing files that change outside of the editor.

To restore your editor, you can go to the console (Project Menu -> Advanced Options -> Open Console) and run the refresh command. It will reset the state of your editor so that you should be able to keep editing from there.

Another possible reason is that your project is out of disk space. In this case, changes you make in the editor can’t be saved in the backend. Make sure you’ve got enough space and try removing packages or other files to make more space.


Thank you very much! It took a while to reconnect but this did in fact fix my problem. :smiley:


Actually, although I thought that it fixed it, my request-promise isn’t installing even though it is in package.json… I had this problem last night but I thought it fixed, apparently not. :thinking:


If you tell me your project name I’ll take a look at it when I have a chance


I believe the reason is because of the --shamefully-flatten option on the node_modules. I get this error when it tries to install stuff:



You shouldn’t be getting this error, are you manually editing your .npmrc file? It would be far easier for me to help if I could see your entire project!

To attempt to solve that, in the terminal you can:

rm -rf node_modules/* node_modules/.*