Glitch Not Letting Me Install This package?

When I install this package: https://www.npmjs.com/package/got
and in my server.js, I put const got = require('got');
but I keep getting this output in console as an error

internal/util.js:214

4:07 PM

throw new errors.TypeError(‘ERR_INVALID_ARG_TYPE’, ‘original’, ‘function’);

4:07 PM

^

4:07 PM

4:07 PM

TypeError [ERR_INVALID_ARG_TYPE]: The “original” argument must be of type function

4:07 PM

at Object.promisify (internal/util.js:214:11)

4:07 PM

at Object. (/rbd/pnpm-volume/a3048a5f-5b3b-48ad-a6d3-d4533d047504/node_modules/got/dist/source/get-response.js:8:25)

4:07 PM

at Module._compile (module.js:653:30)

4:07 PM

at Object.Module._extensions…js (module.js:664:10)

4:07 PM

at Module.load (module.js:566:32)

4:07 PM

at tryModuleLoad (module.js:506:12)

4:07 PM

at Function.Module._load (module.js:498:3)

4:07 PM

at Module.require (module.js:597:17)

4:07 PM

at require (internal/module.js:11:18)

4:07 PM

at Object. (/rbd/pnpm-volume/a3048a5f-5b3b-48ad-a6d3-d4533d047504/node_modules/got/dist/source/request-as-event-emitter.js:13:24)

Which Node engine are you using in packages.json? I suggest you set it to

  "engines": {
    "node": "12.x"
  },

The ERR_INVALID_ARG_TYPE shows with node 8.x but is fixed with node 10.x or 12.x

Good luck!