Glitch "Preparing/Waking Up" Mechanism Failing


#1

When I try to visit https://174a.glitch.me it gets stuck at the “waking up/preparing” screen and fails to move forward.

Was experiencing this when I tried to access my own glitch projects from other devices too. It was always “preparing” for my own Glitch projects too. I went to my Glitch account and forced them to start by clicking “Show Project” - that got it to work both on the device I clicked “show project” on and everywhere else.

Please look into this!


#2

There is probably an error in your code. That message only displays when the code hasn’t finished loading, or failed to load


#3

Hi @HirdayGupta, welcome to the Glitch Forums!

It looks to me like your project (or at least my remix of it) is having trouble building (and thus installing) fibers, which is required by synchronize, which you require in your package.json file.

Reading a little about fibers it seems like it’s sort of particular about how it builds and that may be the cause of the issues.

You should be able to see the errors on install if you run the refresh command in your project’s console and perhaps that can help you troubleshoot the issue.


#4

Hi! Thanks for helping so far. So Hirday is one of my “users”; the page is mine. I actually am not so good with Node. To make this, I simply remixed another glitch page – a mongodb demo. Not sure how to find out which one, but it was that one that made a little blog that saved user text and asked you about your hopes and dreams.

My only dependencies now are express, body-parser, nunjucks, and mongodb. I don’t think I even use “synchronize” so I just took it out of package.json and did console refresh like you said. Now it’s stuck on Node install. It says this, and I don’t know enough about node or glitch to know what to do next:

mkdir: cannot create directory ‘/tmp/.node-gyp’: No such file or directory
mktemp: failed to create directory via template ‘/tmp/tmp.XXXXXXXXXX’: No such file or directory
node v10.13.0, npm 6.4.1
Installing…

Did some major package update overnight or something, and force a reinstall? The page worked before last night.


#5

I just tabbed over again to see if it was still stuck, and noticed that the line “synchronize”: “^2.0.0” is back in my package.json despite having deleted it a little while ago before the console refresh. Can this file change itself? This happened by itself and now it’s giving me messages about fiber like you were seeing.


#6

And now the page works. Can’t really account for anything that’s happened or why it chose last night. Does anyone know?


#7

Right now it seems to me that the fibers issue was a red herring. When I first checked on the project it was using very high CPU for some reason and that could have had something to do with why it was non-functional for a while there. I think we’ll just need to keep an eye on that to see if the problem crops up again.

That said, if you’re not using the synchronize package we should see about removing it to eliminate that from potential causes for concern. I’m not sure why you had the experience that you did, but I’d suggest trying to remove it again and then letting us know if the problems occurs again.


#8

Okay! One fewer dependency, great! I just removed it. Node recompiled quickly and it all works again. It seems the issue was temporary.

I don’t know what kind of request would cause my code to peg the CPU like that but hopefully I find out and fix it so it can’t happen! Thanks for letting me know and for responding so quickly!