Glitch project not starting


#1

My project is stuck at Starting and the issue seems to be different from what everyone else is usually having. It’s not related to port of the listener, nor the project can be refreshed. Here are the details:

  1. I added the .env file myself, and wanted to add a SHEET_ID entry there, but started typing “She…”, then quickly fixed the typo.
  2. Console log says: .env: line 9: She: command not found
    41%20PM
  3. This is the weirdest part: I cannot refresh the app! It refreshes the page, but the refresh command doesn’t output anything and doesn’t finish. 35%20AM
  4. To check that this issue is not related to port or anything else in my code I added the console.log('hey') as the first line of my server script, but it doesn’t execute so that means the project doesn’t refresh automatically too.
  5. I tried rewinding the project twice, deleting the .env file and adding it back and although these changes are saved (fortunately), the app doesn’t change its state.

I’ve tried waiting for the editor to sleep and woke it up again, but it looks like it didn’t change anything.


#2

I haven’t found the solution, but I just worked on another project for several hours and this one now works, finally!


#3

Sorry to hear you ran into problems. I haven’t been able to reproduce your issue adding an .env myself. Let us know if you see this issue again and we can take a look while it’s happening. Thanks.