Hello I need help because I need to be able to use the command for python to help me create a json image ai in python

sudo python3 -m pip install flask

I am trying to install this so I can use this for a

image JSON API

I really need help Please help I know in a recent article glitch staff put that they were unable to allow users to do this. tho it said you could help users find a workaround and I need help with this if you could help I would appreciate it.

If you’re asking if you can use Python on Glitch, the answer is yes. If you search Python on the support forum then you’ll be able to see how people’ve done it in the past.

I hope that helps you.

Does pip install flask work?

Also, Glitch blocks the sudo command.

Uhh no it just throws errors

This is how I got python3 flask to work, credit to multiple people before me lol …

glitch.json

{
  "install": "pip3 install --user -r requirements.txt",
  "start": "PYTHONUNBUFFERED=true python3 flaskserver.py",
  "watch": {
    "ignore": [
      "\\.pyc$"
    ],
    "install": {
      "include": [
        "^requirements\\.txt$"
      ]
    },
    "restart": {
      "include": [
        "\\.py$",
        "^start\\.sh"
      ]
    },
    "throttle": 1000
  }
}

requirements.txt

Flask

flaskserver.py

from flask import Flask
app = Flask(__name__)

@app.route("/")
def hello():
  return "Hello World!"

if __name__ == "__main__":
  app.run()
1 Like

Glitch does not provide official support for languages or frameworks other than Node.js. Although, some languages or frameworks may work.

All Node packages should work fine (require them and include them in your package.json file).

1 Like