Help with custom URLs?

I am trying to add a custom URL to my glitch site. I added the CNAME to my DNS records about ~6 hours ago. I bought my domain from domain.com.

When I go on the project that I added it to (be-e.glitch.me), it doesn’t show anything, just shows the default screen to add a domain, and my domain has already been put on a project.

image

Help me out here.

@cori (check this out for me please!)

  1. DNS propagation can take up to 72 hours (3 days). Could you try waiting/clearing DNS cache for a few public DNS servers?
  1. You aren’t supposed to ping staff members. Getting Help From Support Staff
4 Likes

I went ahead and cleared the cache on both. Still not going to my glitch site. If there’s no change within the next few days I’ll get the domain removed from my project and redo the DNS

1 Like

Hi there @Bee
Would recommend you read up on DNS Propagation, as suggested by @aboutDavid
Here’s a great video:


TL;DW: DNS is updated at different times across the world, providers, ISPs, etc. so even someone on a computer next to you can view the updated version, but you have the non-updated, and vice-versa
Incognito always helps and using this on windows cmd:
ipconfig /flushdns

Hope this helps! :slight_smile:
Eddie

4 Likes

Hi again @Bee
I was wrong before when I said the site worked fine.
Instead on your custom domain, I get this error:
not found: www.be-e.us
which means you have registered the domain as be-e.us and not www.be-e.us and your DNS provider is redirecting all requests to www.
You can either ask support to remove the domain so you can add the www. prefix (you can make a ticket on the Help Centre or email support@glitch.com), or you can stop your DNS/domain provider from redirecting the requests to www
Hope this helps! :slight_smile:

1 Like

Thanks for the reply.

So I messed up when adding the custom url? It should have been www.be-e.us not just be-e.us ?

@EddiesTech


Hi again @Bee As you can see in this gif, the site redirects from be-e.us to www.be-e.us. This either needs to be reflected when adding the custom domain on Glitch or by stopping the redirect (probably a setting on your DNS provider’s dashboard)
If you would like to change the Glitch custom domain, you can email support@glitch.com or create a ticket on the Help Centre
Hope this helps! :slight_smile:
Eddie

1 Like