Hi Problems is better_sqlite3.node

javascript

#1

Hello

Some modules in Glitch cannot be loaded

Especially the general problem better-sqlite3

we were using shrinkwrap.yaml and enable-pnpm to solve this problem, but please take this workaround to eliminate this problem as soon as possible

better-sqlite3 error:

   module.js:550

    throw err;

    ^


Error: Cannot find module '../build/better_sqlite3.node'

    at Function.Module._resolveFilename (module.js:548:15)

    at Function.Module._load (module.js:475:25)

    at Module.require (module.js:597:17)

    at require (internal/module.js:11:18)

    at Object.<anonymous> (/rbd/pnpm-volume/aaec3d2d-aebb-4535-97bc-3451acb56ac6/node_modules/.registry.npmjs.org/better-sqlite3/5.4.0/node_modules/better-sqlite3/lib/database.js:5:21)

    at Module._compile (module.js:653:30)

    at Object.Module._extensions..js (module.js:664:10)

    at Module.load (module.js:566:32)

    at tryModuleLoad (module.js:506:12)

    at Function.Module._load (module.js:498:3)

#2

Hi @MeliL, the better-sqlite3 package in particular seems to have problems for some reason we’ve never been able to isolate. If this is frustrating for you, I suggest using a different sqlite package on Glitch if you can.


#3

Can you type "enable-pnpm " Into the console and assign your Node version here by typing "node-v "?


#4

@cori I hope this will be corrected sooner
@SepulturA node v = v8.15.0