Hostname reserved


#1

Hello,
I just want to host my domain through fly.io but I always get the error of my hostname being reserved. Can someone please clear it up from your record as well as fly.io’s. I am extremely sorry that I am repeating this error more than once. Domain: www.valk.space
Thanks
Deni


#2

Hi @Deniernal354 we’ll also need the project you’re associating the domain with before we can remove the custom domain from fly.io (sort of a safety check).

Also keep in mind that www.valk.space and valk.space are different domains so if you want both removed we have to know that too.


#3

Ok here is my here is my project link and I would love if you can remove both domains since I thought that they were the same thing but I found out that my www.valk.space domain actually loads and the other one doesn’t. Also thanks for the super speedy reply.


#4

Ok information received, thanks!

I have to double check with the folk sat fly.io about this one; I’ll post back here when we’ve got it cleared up.


#6

Alrighty! The folks over at fly.io told me that they worked with you to get this cleared up on their end, and I’ve removed it from our end, so things should be all set for you now.

Please let us know if you have further questions or problems, and happy Glitching!


#7

Hey could you remove the record of the domain from your side and from fly.io’s side please. I’ll try to go through this process one last time through the steps of going to my project adding the domain and adding that CNAME record to my cloudflare DNS records. Is that the correct method of doing it?
Thanks


#8

That’s what I was trying to say; my apologies if I wasn’t clear: www.valk.space has been removed at fly.io based on your email to them and from Glitch based on this topic. Glitch has no record of valk.space associated with any projects.

I believe you’ve got the process right, but just to be explicit it should be:

  1. Go to your project’s Advanced Options menu and select Custom Domain
  2. Enter your domain (www.valk.space). Make a note of the shw.io domain that’s displayed when you do so.
  3. Go to your registrar and add a CNAME record pointing www.valk.space to xyz.shw.io. Wait a bit for that to propagate through the DNS network (it’s usually pretty fast, but depending on where you are it can take up to 24 hours or so).

The process is probably slightly different if you plan to use valk.space instead of www.valk.space - that’s laid out in our help docs.


#9

Ok thanks alot for that detailed explanation I will now go and follow your explanation and try to get this working at last. I really appreciate your help and your persistence of continuing with me on this topic.


#10

Hey @cori this is what I’ve done. Is it correct?



Also one more thing @cori would I be able to assign both domains at once www.valk.space and valk.space which will point to the same glitch project?


#11

That looks right, although it’s not showing up for me yet - you can take a look for yourself here. You should see a CNAME record on that page once everything’s working properly on the DNS end of things - if you don’t see that by tomorrow I’d suggest talking to your registrars support-folk.

You can just use the same process to add valk.space to that project, but depending on your registrar’s options you’ll either need to add an A record or something custom (might be called an ANAME or ALIAS) - basically the DNS system won’t let you point a CNAME at an “apex” domain (like valk.space) so you need to work around that. That process is described in the help doc I linked to, but the exact steps depend on what your registrar allows.


#12

Ok I tried doing that but that didn’t work since my domain registrar didn’t allow me. But it is ok since I got 1 domain working which is the point of all of this. Thanks for your awesome help and support Cori.