How do I get a folder that I created in the terminal to show up in the file tree?

Howdy, folks-

I created a folder named “fonts” (within my “public” folder) in terminal, and uploaded two .woff files to it (using wget).
Screen Shot 2021-08-31 at 6.19.01 PM

However, it doesn’t show up in the file tree (the list of files and folders, next to the where you edit code), even after refreshing the browser… I had a screenshot but “new” users can’t upload more than one photo… yeesh.

Anyway, what can I do?

Thanks :slight_smile:

Maybe you can run cd fonts?
(If you want the folder after his creation using the terminal in the Glitch editor, run refresh)

Thanks for the suggestion… but it doesn’t do anything.

I am trying to get the “fonts” folder to appear in the file tree next to the editor:

You have refreshed the editor?

yup.

i even closed and relaunched my browser and logged back into glitch.

And what is the output of the terminal when you cd into the fonts folder?

check it out:

It’s should work so if you include these files in your website.

yeah… it doesn’t, which is why i asked my question in the first place :frowning:

Hi there - did you run the refresh command in the terminal? If that doesn’t work, email support@glitch.com and we can take a look!

hi, jen- i’ve tried refresh (as per your and @Stilic 's earlier recommendation) but alas it did nothing :frowning:

i’ll send an email.

thanks!

The editor only deals with textual source code files. I would think that this excludes .woff font files; i.e., they’d be excluded from the files listing.

The other thing going on here is that “empty” folders aren’t shown in the files list either. Your fonts directory isn’t empty in the filesystem sense, but it would count as empty in the editor-for-text-files sense.

What I would try is creating a text file in that directory and then running refresh again.

cd public/fonts
echo placeholder >placeholder.txt
refresh
3 Likes

That worked!

I used your solution to create two files,

izzyfuss-regular.woff.ph
izzyfuss-number-bold.woff.ph

but it’s a bit of a janky solution…

Thanks!