How to change website from a git

I’m wondering how to update my website from a git. I’m experimenting with a code editor for my iPad and I cloned my git repo and works perfectly… up until I try to commit my changes. It says “upload failed”. I have a feeling this has to do with glitch itself but not the code editor. Please help!

committing should work, but pushing might not work in the default settings. see about receive.denyCurrentBranch here

I tried that and then this came up

you couldn’t resist slapping that into the terminal as is :frowning_with_open_mouth:

2 Likes

sorry for the long reply, i pasted the command in the terminal the right way and now pulling and committing doesn’t throw an error but now it does nothing. pushing however still throws an error saying

Pushing changes…
Writing objects: 0.0%

Push upload to remote failed

I have a feeling its because of how I cloned the git since I used SSH instead of HTTPS

how’d you get connected to your Glitch project repo via SSH?

I just pasted the git url in and it cloned it

glitch gives HTTPS git urls, so is it possible that this whole thing wasn’t working because you were pushing to somewhere other than glitch?

Maybe but it cloned perfectly

what was the SSH URL? redact any tokens if necessary

do I have to? the project includes my real name my name is not ‘someone’ ik big woop and I don’t want to reveal it yet. but all I did was just copy the project’s git and it worked

you can redact the name too (:

but I’m still curious

any project will work though

https://(token)@api.glitch.com/git/(project name)?

1 Like

I signed out for this

https://3af49075-d859-4012-b1d0-bb96fe5f0893@api.glitch.com/git/sepia-gamy-cook

1 Like

thanks for checking. that’s an HTTPS url, not an SSH url, so it shouldn’t be a problem related to ssh

This time I cloned my git with the https method and it cloned perfectly. However pushing, pulling, and committing does nothing but when you push it still throws an error

1 Like

they shouldn’t do anything, right? i.e. you’ve made no changes to push/pull/commit?

can you show your git config, just to make sure the above denyCurrentBranch thing stuck?

I did make changes

All i did was paste the following into the terminal

git config receive.denyCurrentBranch updateInstead 
echo 'refresh' > ./.git/hooks/post-update
chmod +x ./.git/hooks/post-update

hm and that even looks fine

still throws an error

is it a different error then?