How to install current Haskell toolchain on Glitch?

I see that GHC 7.10.3 is installed:

$ /usr/bin/ghc --version
The Glorious Glasgow Haskell Compilation System, version 7.10.3

but unfortunately this is very out of date (that version was released in December 2015). It doesn’t seem like 200MB is enough space for me to install a newer version using ghcup, so I was wondering: is there another way to get a newer Haskell toolchain on the container?

Hi @vaibhavsagar

Thanks for the feedback! I will share your request to update the Haskell toolchain with our team.

1 Like