How to make a glitch project to run constantly?


#5

I still cant get it working did everything you said and still cant got discord? if so mine is :crown: 𝕿𝖍𝖊𝕯𝖊𝖆𝖙𝖍𝕾𝖙𝖗𝖊𝖆𝖒𝖊𝖗√#6228, Thanks!


#6

Are you getting any errors from it?


#7

You could also just create a simple websocket server and connect to it and have that ping at least once every 5 minutes, that will keep your bot running and the server will be up as well, but I recommend pinging once every 30 seconds. Make sure this is not made in the same project as your main project folder. Glitch shuts down applications after 12 hours of running, so if you do that, the whole application stops and no pings will be sent.


#8

It isn’t showing the page! Can you send a new link?


#9

This method seems not working anymore.


#10

Hi @YzY229, welcome to the Glitch Forums!

If you mean that using UptimeRobot’s not working to keep your project awake then can you give us some more details? Project name, UptimeRobot config, any errors you’re seeing in the Logs pane? As far as I knowledge lots of other folks are using UptimeRobot successfully.


#11


#12

Isnt working for me too, I did all exactly steps showed here.


#13

Assuming I’ve got the right project for your case @Zoilken, the problem is probably that your app’s not serving anything at its homepage url. I’m not a Flask expert, so I’m not quite sure what’s wrong in there, but even just returning “Hello World!” from your root() method would mean there’d be a page there - without a page of some sort there UptimeRobot has nothing to load to keep your project from sleeping (and that’s also why UR thinks your app is down).


#14

@YzY229 again assuming I’ve got the right projects based on my guesswork from the screencast you sent, your problem seems like it’s the same root problem that @Zoilken is having: your projects aren’t serving a webpage at the address that you’ve configured UptimeRobot to load and so 1) UptimeRobot thinks your project is down because there’s nothing at the address you told it to watch and 2) because UptimeRobot can’t load anything where you told it to look it’s not actually keeping your project from sleeping.

You’ve still got Express in your package.json files (at least the ones I looked at) so you need to do something like what you see in this file in our Express starter project. Basically, set up the Express app, tell it to do something when someone requests the homepage of your app, and start listening to the appropriate port You could probably copy the contents of that file and paste them at the bottom of your server.js file (assuming you have a file to render at the location listed here) and everything would work fine.


#15


Copied everything and don’t know why only one is up in the dashboard even I have loaded up four of the bot’s page.

(I have tested it and it didn’t work. So I try to load up the four pages and see how the uptimerobot page react.)


#16

@YzY229 can you post screenshots of your UptimeRobot configuration for the ones that appear down?

Here’s what I get for bot-silence, for instance:


#17


#18

If they all look like that then I’m not sure why they seem down from UptimeRobot’s standpoint - they’re all up and running on Glitch’s end as far as I can tell. Maybe export the logs and see what the error messages are, or contact UptimeRobot’s support?


#19

I reset stats and everything seems to work now.


#20

Hey guys,
I followed the steaps which were mentioned at the beginning, but it does not work and I didnt’t get any alerts per email


#21

Hi @Basti_Basti, welcome to the Glitch Forums!

Can you send screenshots of your UptimeRobot config and monitor status so we can validate that?

A link to or screenshot of the address you have UptimeRobot checking would also be helpful.


#22

perhaps things mentioned in that post will help.


#23

Uh, issue here… I did this, and waited for about 15 minutes. It has not even started yet? Images below.
Settings
Dashboard


#24

Oh, disregard that previous message. They were only down for maintenance.