HTTP upgrade supported protocols


#1

Requesting a protocol upgrade to something other than websocket fails. It’s been a while since I last tried, and I don’t remember exactly how it fails, but I hope you know what I’m talking about.

Is this because Glitch’s router needs to do something to upgraded connections? Let’s talk about it.


#2

Yes, there’s work to be done in the routing if we want to support upgrading to other protocols. What are you trying to upgrade to?


#3

To a raw byte stream.

What level of support do you intend to provide to other protocols, other than handing the connection over to the app?

I checked to see what happens when a connection upgraded to websocket actually transmits something other than the websocket protocol, and it worked fine. Are there any advisories on doing this?


#4

I don’t really understand what you’re asking. If you’re trying to use a raw byte stream, how could we provide other support? We don’t know what you’re going to be sending through it.

We don’t care what goes through the websocket once it’s established, so if that’s working for you, go for it!