I am receiving the below error when trying to use puppeteer, it seems that this error happens when i upgrade the nodejs version

I am receiving the below error when trying to use puppeteer


/app/node_modules/puppeteer/lib/Launcher.js:255

8:27 PM

reject(new Error([

8:27 PM

^

8:27 PM

8:27 PM

Error: Failed to launch chrome!

8:27 PM

8:27 PM

8:27 PM

TROUBLESHOOTING: https://github.com/GoogleChrome/puppeteer/blob/master/docs/troubleshooting.md

8:27 PM

8:27 PM

at onClose (/app/node_modules/puppeteer/lib/Launcher.js:255:14)

my setup

    const browser = await puppeteer.launch({
      headless: true,
      args: ['--no-sandbox', '--disable-setuid-sandbox']
    });
    const page = await browser.newPage();
    await page.goto('https://developers.google.com/web/tools/puppeteer');
    await page.screenshot({path: __dirname+'/public/puppeteer.png'});
    await browser.close();
    response.sendFile(__dirname+'/public/puppeteer.png');