I heve a problem creating a new glitch project using a git repo!

I’m making a new glitch project by pressing New Project -> Clone from Git Repo, I insert my link. I’m not getting any error and when the project opens it is not my git project, is another project, I guess some glitch pre-created project. Can you help me add my git project to glitch?

@octavi42,

If cloning from your git project doesn’t work, you could always try Import From GitHub in a new project! In the meanwhile, I’ll try Clone from Git Repo and see what I get.

Yes! It doesn’t work! @octavi42, thanks for pointing out this bug. @support_staff (or @jenn or @tasha), I tried cloning my GitHub project by getting the Git link generated by GitHub, and when I entered it in the textbox, I just got a remix of hello-express rather than my Git repo, as @octavi42 describes. I believe this is due to (correct me if I’m wrong!) the recent Glitch downtime. My logs are filled with

! (It’s after I deleted my project)

Do I have some alternatives?
I tried to with “Import from GitHub” inside a project but that didn’t worked for me aswell.

@octavi42,

Are you sure this is how you imported from GitHub?

I tried to import the git repo from Tools… but I’m getting this error: “We’re sorry, something went wrong! Please try again, or try refreshing the editor.”. Do you have any suggestions?

I had 2 folders in my repo, I deleted them and it worked, I can import the git repo. But why is it not working with my 2 folders?

It might need to be an empty project???

In my case it works if it is an empty project or not. I think there is a problem with creating the folders in glitch. If I try to create them like this: New File, (file name, ex. folder/data.txt), Add This File It works, the folder is created.

How do you add files otherwise?

Inside my project I:

New File -> (file name, ex. folder/data.txt) -> Add This File

1 Like

Hi @octavi42,

Thanks for your report! Our team is looking into this now. I’ll provide an update once it is fixed.

@octavi42

This bug has been fixed. You should now be able to use the ‘Clone from Git Repo’ option in the ‘New Project’ drop-down menu.

If it still does not work for you, please let us know!