I need help with custom domain!

#1

image

What does this mean, Like i go to dns options and do what??? Like where on the picture down bellow do i add the stuff from glitch, I don’t understand!!!

EDIT: I got it to kinda work, like when i do www.ramfish.tk the site showes up. But there is 2 problems,

  1. It’s not safe. like it has no https or whatever it is: image
  2. Second is that it only works for www.ramfish.tk and not ramfish.tk or https://ramfish.tk how do i make it work for those last 2
#2

Hey @ramoth123, ramfish.tk is set up in Glitch (and fly.io) so now you’ll needs to set up a DNS record like you did for www.ramfish.tk to point ramfish.tk to the fly.io server. What, exactly, you need to do depends on your DNS provider, but https://glitch.com/help/custom-domain/ provides some background and information about what you’ll have to do.

HTTPS should work if you’ve got things set up correctly, but when I look at DNS for www.ramfish.tk I don’t see it set up properly. That record should point to the shw.io domain you have listed above (or you can point it to glitch.edgeapp.net instead, which will work the same). Currently there’s not a good solution for forwarding all requests to HTTPS when using a Glitch custom domain, but I’ll talk it over with our partners at Fly to see if we can come up with something.

#3

Wait so @cori , Ihave to go to freenom and do www on the left and set it to CNAME then add the fly link to target, then go to this page https://fly.io/ Then what. Like could you go through it with me here, and what link to i even paste in the target and everything!
Like all i want it to have my domain ramfish.tk to direct to my glitch site. Without www and with https safety. And also this comes up image

#4

Yep, you’ve already registered both www.ramfish.tk and ramfish.tk for use with Glitch via Fly.io. Everything should be set up on the Glitch end of things.

To send the www.ramfish.tk domain to your Glitch project you’ll have to do as you mentioned. What you need to do to get ramfish.tk working depends on your DNS provider. Some have a workaround that will let you use another domain name like what you’re doing for www.ramfish.tk, but most will require you to use an IP address. If that’s the case you can use the same tool I pointed to before to find the IP address of glitch.edgeapp.net. All of this is discussed in some detail in the help article I previously mentioned: https://glitch.com/help/custom-domain/, which also links to the Freenom help docs for this process. I don’t use Freenom, but I think you’ll want things to end up looking like this:

Those settings will mean that it will take roughly an hour (3600 seconds) for these records to show up.

#5

So now i have this, as the documentation said i need to do shw.io and the link i get in glitch, but how do i direct it to my site, it doesnt say in the docs

#6

In the top record you’ll need to use www, not shw.io - Freenom calls that the name, but it’s actually the subdomain address that they want to see there. Right nowe you have it set up for shw.io.ramfish.tk, which doesn’t have a custom domain record in our or fly.io’s systems, so it shows up as not found.

For the second, just like you have it will work, but you need to use the IP address I showed, or the IP address for your shw.io domain. Either will work.

Once you make those changes and wait for them to make their way around the internet things should work more like you’d expect them to.

#7

So i change shw.io in the name to WWW

So like this or?

1 Like
#8

That looks right to me, and it looks like it’s working!

#9

YEAH it works, but its not secure. How do i make it secure??? image

#10

Glad it’s working. As I mentioned above, there currently isn’t a workable way to force your project to use HTTPS when using a custom domain, but as long as you follow the HTTPS address the SSL certificate should work just fine.

#11

Yeah, but when i try and add the site to cloudfare it says it already is added, but its not safe and secure, like wot

#12

If you want to share your CloudFlare config here so someone might be able to take a look, that’s fine. Without that I don’t have any guidance to give beyond what I’ve mentioned.

#13

Ok thank you, but it says if I want to add the site to cloudfare, i have to change the name servers, which i cant do because it has to be default for the glitch thing to work. So could i get someone who knows this stuff?

#14

Hey @ramoth123 one thing I didn’t mention is that you can set up a custom domain to force HTTPS if you set it up more manually like is outlined at custom domain on fly.io. Perhaps that’s more what you’re looking for than the relatively simple custom domain support that’s baked into Glitch.