I think i found a bug with the asset folder


#1

Hello,
i noticed something annoying about the assets folder, when i tried to access it on another machine when i wasn’t logged in, i could remove and add assets to that folder.
Can you fix that please?


#2

Thanks for reporting this, but I can’t reproduce this issue. Can you let me know your browser version and OS. Also, how were you uploading assets - with drag and drop or using the file upload in the assets folder UI? Thanks.


#3

Both computers were running on chrome & windows (7 & 10), i used both methods.
The only fix i could find is locking the source so the peoples can’t use the editor to remove or add assets.


#4

hmm, still struggling to reproduce. If you could DM me a joink link for your project, I’d like to take a closer look at the assets folder, thanks (see https://glitch.com/help/how-do-i-invite-collaborators-to-edit-my-project/)


#5

Are you sure you’re not a project member on both machines? You can be a member of the project even if you’re an anonymous user (not logged in).


#6

I don’t think so…
I didn’t added any machines manually.
I don’t know if it’s fixed since i used the lock icon thought (Only members access)


#7

how do i send private messages please? (I could not find the button to PM you…)


#8

Click on my name and you might see the option to send a message. If not, then you might not have enough forum points yet so just email me it instead - gwilson@fogcreek.com. Thanks very much!


#9

Are the two machines anonymous? I am pretty sure that if they are on the same network and anonymous everyone would have access to them. You would have to check with the staff though.


#10

Hello,
They weren’t on the same network.


#11

Yes, was able to reproduce from another machine ( in another network by RDP ) and without an invite link by only clicking the “Delete” button in the remote browser then they instantly disappear in my browser, it works on both, default tutorial assets and custom ones,

Couldn’t upload in any way, drag and drop redirects to the file:/// page / CTRL + V shows this :
image
There is no “Add asset” button and even removing the hidden class from the button to and uploading returns a 401 error,

You don’t really need an invite link though, you can delete any asset in any public project.


#12

Thanks - I was able to reproduce this too. We’ll get it fixed up as a priority.


#13

This is fixed now - the Delete button still shows in the UI (we’ll get to that shortly) but it doesn’t do anything.


#14

Yes it seems to be fixed now ! Thanks :smiley: