I'm having security issues without node v18+

Some proxies think my streams are suspicious, and I tried the same code on node 20, and everything worked fine. Is there any way that you can add node 20 support?

This needs to be higher up.

Node v16 now only gets maintenance patches and is scheduled to no longer get updates in a few months. Node v18 is still “Active”, meaning routine patches will occur- and it also gets new features.

how do they know what version of node you’re using?

they looked up my project

So you’re saying that glitch will have to move their support to node 18 soon?

Most likely. Hey @wh0 since you’re here what’s your estimate?

I have no visibility into their development timeline. there seem to be fields in their API for identifying a version of the project container though, so I’d believe they at least are working on it

"placementCategory":"xenial_classic"

edit: to clarify, while you asked about node.js, not Ubuntu, the reason it’s related is that the current project containers’ Ubuntu 16.04 base is too old, and they can’t just get node.js 18+ on them Node v18.0.0 (Current) | Node.js

Prebuilt binaries for Linux are now built on Red Hat Enterprise Linux (RHEL) 8 and are compatible with Linux distributions based on glibc 2.28 or later, for example, Debian 10, RHEL 8, Ubuntu 20.04.

exciting. well, I can’t wait for that day.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.