Import from GitHub fail


#1

I receive the message : “Arg, something went wrong. Try again? :@” when I try to import my repository, yet I respect the syntax name/repo, I have this problem since I resumed my project and it worked perfectly before … I spent the day to test a little while telling me that it had to be a bug (revoke / re-grant access …) but nothing has changed, I try to export too, it tells me that it works but a push request does not appear in my git :frowning:


#2

Hi @Dowar, welcome to the Glitch Forums!

I just tested github import/export and they seem to be working fine overall, so it seems like something specific to your configuration. Can you share your github username and the repo you’re trying to import? Does the same thing happen if you try to use the clone-from-repo option in the editor’s New Project menu?

And just to make certain you’re aware, when you export to your github repo the exported project will end up in its own branch, not on master.


#3

I downloaded my project on my pc, i put it in another repository and i imported it via https://glitch.com/edit/#!/import/github/name/repo into another project glitch, and it seems to have solved the problem, I can now import without error ^^ sorry for the inconvenience! for the branch yes I was aware, I even made glitch my main branch and it always worked;)