Import from Github fails everytime

I was using Glitch for my Discord-bot about 1 years.
But recently, Import from Github not work with error.

Arg, something went wrong. Try again? :@

No log, No error message but “Arg, something… :@”. Oops. What the hell this emoji?
How do I solve this? Infinitely “Tray again”??? or Do not import?

Thank you for your time

Hi @neoarc, welcome to the Glitch Forums!

We’ve seen a couple of reports about this recently, but I haven’t been able to reproduce it reliably. If you can provide your project name and the github repo you’re importing and confirm that you’re using the “Import From GitHub” button from the Project Name -> Advanced Options menu (and not the “clone-from-repo” new project option) maybe we could track it down.

I’m also curious if you’ve tried using the project console to pull the repo in manually and if that is any more successful. We don’t expect people to have to use that method, but if it works and the “Import from…” button doesn’t that might help us track things down.

Hi again.

Sadly, It’s private repo with big secure data. So I can’t share.
I did pull from console and got this error:

remote: Counting objects: 100% (81/81), done.
remote: Compressing objects: 100% (48/48), done.
remote: Total 740 (delta 37), reused 65 (delta 28), pack-reused 659
Receiving objects: 100% (740/740), 2.97 MiB | 1.52 MiB/s, done.
Resolving deltas: 100% (450/450), completed with 7 local objects.
From https://{my-github-repo}
* branch HEAD -> FETCH_HEAD
error: Your local changes to the following files would be overwritten by merge:
Please, commit your changes or stash them before you can merge.
error: The following untracked working tree files would be overwritten by merge:
Please move or remove them before you can merge.

“shrinkwrap.yml” is not my file and I have no idea why this file created.
Anyhow, I’ve manually delete 2 files and could pull.
When pulling, text editor opened automatically. There was some text about merge thingy. (I don’t remember)

I recommend show pull/merge error message to user,
Instead of “arg, something went wrong. Try again? :@

— Additional
This happened again after pull manually.
Pull & merge function seems like not work well.

– Additional 2
After manual pull, some file is missing so I’ve manually add it using “New File” menu. :frowning:

Probably what happened here is that your git repo got stuck in an inconsistent state (most likely do to an incomplete checkpoint commit). Once there it couldn’t commit checkpoints any more which is why you had a few files that weren’t committed (and then the merge errors and the subsequent problems, which were continuations of the problems with your repo).

With your project name I could have looked at our logs to see what the error messages from the git operations were but we might be able to do a better job of delivering at least some info to the user when this happens.

Shrinkwrap.yaml is a file used by pnpm to keep track of your package installation.

Sorry for the bother and glad you got it worked out!

3 posts were split to a new topic: Importing from GitHub fails when logged out