ImportError: No module named 'uvicorn'

At some point recently my Glitch stopped working, and I’m not certain why. This isn’t really my area of expertise, so I kind of had a “set it and forget it” approach once I had it working. This error is being pumped out constantly:

Traceback (most recent call last):

  File "/app/.local/bin/uvicorn", line 5, in <module>

    from uvicorn.main import main

ImportError: No module named 'uvicorn'

Is this related to the python rollback that seems to have happened? I can’t seem to install uvicorn. My scripts failing might be due to this or might not, but I’m hesitant to troubleshoot more until I get this issue fixed.

My requirements.txt contains both:

uvicorn
fastapi[all]

Thanks for any help.

I’m gonna guess this is the same problem that I and many others have been facing. This is because of glitch’s unintentional bug where python degraded to version 3.5.2, which is outdated and is not support by many libraries such as discord.py and likely the library you are trying to use.