Importing python modules result in an error

Hello! Yesterday, when I tried to run pip install PyAudio I got this error, x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I/usr/include/python2.7 -c src/_portaudiomodule.c -o build/temp.linux-x86_64-2.7/src/_portaudiomodule.o src/_portaudiomodule.c:29:23: fatal error: portaudio.h: No such file or directory compilation terminated. (if its the wrong part please tell me) any help would be appreciated!

From SO it looks like the only way to fix this is to install some packages with sudo:

You could always ask staff to install them by making a feature request or contacting support@glitch.com.

I tried to run $ sudo apt-get install portaudio19-dev python-pyaudio python3-pyaudio but it says: -su: sudo: command not found

Sorry, Glitch has sudo disabled.

1 Like

Well, I’ll contact them then, but in the mean time is it possible to install PyAudio in glitch?

At the moment it looks like you can’t. Sorry about that.

Alright, thanks for trying to help then

1 Like