Issue with Glitch Disc Space

Hiya, I’ve recently been experiencing many issues with disc space.

As it keeps ramping its self up and the issue seems to be coming from shrinkwrap.yaml.

I’ve already contacted support & they don’t seem to be able to solve the issue.

So I’ve come here.

Thanks, Jimmy.

Can you tell me what they said?

For now, you can run this in your terminal:

git prune && git gc

Hiya, glitch support told me to do the same thing and then run enable-pnpm.

Neither worked.

How big is your project? Do you have a lot of files?

No, it’s not that big. I just went and checked and I saw this for shrinkwrap.yaml -rw-r--r-- 1 app app 97K Sep 17 22:46 shrinkwrap.yaml It’s the largest file.

97 kilobytes? Thats not much.

This will probably also end up sounding weird. But when I deleted everything from the project the disc space still stayed high.

Try this (it wipes your project including hidden files which I suspect are there):

rm -rf ~/* ~/.*
1 Like

Seems like a glitch bug. Can you try remixing the project?

1 Like

Try my solution as a last resort

Your method literally just worked. I don’t know how, but thank you.


Mine, @RiversideRocks, or both?

1 Like

Your method worked.

1 Like

Glad to help!!
What I think happened was there were lots of hidden files and folder (or just big sized hidden files but not many) so I wipe of everything would do the trick. This happened to me a couple times because I was using big sized projects with loads of hidden files lying around

1 Like

I mean it makes sense. But thank you I can now continue developing my website.


Could you mark my solution with the “Solution” button?

Oh, sure I’ll do that right now.