Issues editing/inviting to a team


#1

Hey! Me and a few others who code in our spare time are trying to get a glitch team set up (@boxofdevs): we’ve got the team, but for some reason I don’t seem to be able to add new users (from my side it looks like I’ve added them, but from their side they can’t join), and every time I try to upload a logo/icon this happens: image

I understand it’s in beta, so it’s not likely to work perfectly, but that’s some pretty broken behaviour.


#2

Can confirm I’m having issues joining the team. I got a email invite, but the link didn’t work.


#3

Thanks for the report, folks! We’ll take a look and see what we can find and let you know!


#4

I was able to join with a new invite.


#5

Ok that might make sense. Each invitee can only have one active invite token, so if someone has been invited more than once earlier tokens will be invalid. Is it possible that’s what happened the first time around?

I’ve been able to reproduce the image upload error and will forward that along to our devs.

Thanks again for the reports!


#7

That’s probably what happened because I had multiple invites in my email.


#8

I just tried uploading a new cover to my team and was able to do so without any errors, so you might try that again. I’m not quite sure why it’s working now, but it seems like it may have been a temporary … glitch.


#9

I’m able to upload new covers without any issues, it’s the avatar that isn’t working. Tested again, exact same error.


#10

Ah, thanks. I missed that but was also able to upload an avatar for a team successfully just a few minutes ago. I doubt that this is cache-related, but just in case can you try from an incognito window?


#11

Yep, same error when trying from an incognito window (Chrome) and when trying with a newly created team.
Tried it in Firefox, got the same error. Tried in Edge and came up with a different error:

Interestingly, though, I was able to upload from another device (Chrome Mobile), so not sure what’s going on there.

EDIT: I just tried with a few other files - I was able to upload .jpg and .png images with solid backgrounds (likely why it worked from my phone), but any images with transparent backgrounds (.png and .svg) provoked the error.

EDIT: Now this is really weird. I’m still getting the same error, but when I reload the page the new avatar is there. Not sure what changed to make things start working(-ish).


#12

The new icon is there for me. Strange.


#13

Thanks for the additional detail; we’ll definitely take a look and try to pin this down.


#15

Hey folks, by the way we think this is fixed. Please let us know if you have additional issues.