Issues while editing code

So I encountered this error once but I don’t know how it got fixed, so the error is when I write or do spaces, instead of making space, it goes to the other word
Example:
I have this part of code

module.exports.help = {
name: "kick"
}

And I want to edit the kick to be ban
so this happenes

module.exports.help = {
name: "ban
}

Like I highlight the kick word and when I want to right ban this happens
I tried refresh and enable-pnpm but no luck
any help?

You made a mistake in your code - I think.

name: “ban should be name: 'ban”

Dude, thats his issue lol

The program is forcing the code to look like that.

Yes, I know I made a mistake but this happens from the editor itself

@RiversideRocks Whoops… Not good at bots… Could you send a screenshot @HeemPlayz

1 Like

I will try to shoot a video

2 Likes

It might be a bug with CodeMirror, if so you could reach out to them on GitHub.

ezgif.com-video-to-gif
This is what I’m dealing with all the editor

Are you on a PC? That happened to me before.

Yes, I don’t use mobile at all

Tap Insert. It works all the time

1 Like

From Computer Hope:

Sometimes displayed as Ins , the Insert key is a located on most computer keyboards near or next to the backspace key. The Insert key toggles how text is inserted by either inserting the text in front of other text or overwriting text to the right of the cursor as you type.

1 Like

Worked, thanks a lot @anon69241012 @EddiesTech

1 Like

Wonderful! Hate that key! :slight_smile:

No problem! @RiversideRocks do you still have that Glitch Error blog post thing?

I think it got deleted when I redid my website. It is probably still available on github, I will pull it up.

OK. You should add this :slight_smile: