Keep getting gateway timed out


#1

My bot suddenly started give an error saying gateway timed out everytime it tries to connect to discord gateway, i don’t know what’s happening, if this is a ip banned or something like this :frowning:
can any glitch staff take a look into my project?

Project name: nikobotdev-niko

Screenshot


#2

Hey @NikoBotDev I took a quick look at your project’s logs and I don’t currently see the error, so I don’t think it’s likely to be a blocked IP address; that wouldn’t typically be intermittent in that fashion - you’d either be blocked or not blocked.

What else is happening in the bot around when you see this error? Does it happen at a consistent point in the code?


#3

Hey @cori thanks for the fast reply as always :smile:

in the logs panel it shows only redis logs

it happens everytime the bot goes on, and i tested locally and it works fine so it’s not account ban
and i tried login in another bot on glitch and it works fine too, so ip ban isn’t a thing in this case
i don’t know what’s happening :frowning:

– EDIT –

I forgot to say that if you really want to see the logs use the command below
(i can send you an invite if necessary)

cd .pm2/logs && cat Niko-e*

#4

Ok good to know about the logs, thanks.

Just having another bot working doesn’t rule out an IP block - different projects can have different origination IPs; what’s the other bot project’s domain?


#5

That’s wasn’t what i meant, i just changed the token to another bot token in the same project and it worked fine, it’s just a specific bot that doesn’t connect on glitch


#6

So, the same code in the same project works fine when registering as a specific bot (using a token “A”) but gets a gateway timeout when registering as a different bot with a different token (“B”)? And token “B” works fine elsewhere?


#7

Yes, using the token that the project is for in that case is my bot called “Niko” doesn’t work on glitch bot but on my pc it works fine


#8

@NikoBotDev How do you use pm2 in glitch without getting RAM high?


#9

Ok, it looks like perhaps you’re actively working on this - I browsed the logs as you indicated and still don’t see the gateway issue - instead some redis errors and some invalid token errors.

Let us know how you get on, and if you’d like us to look more closely at the gateway problem when it’s occurring.


#10

Sorry @cori i removed the token because i was afraid that if the program tries login so many times i could get api banned :frowning: but i can add it again if you want to and also send the log files

__ EDIT __

I think that error could be because my bot is in 1100 servers and this cause connection issues but glitch connection looks fast enough since i ran the “ping” command in console and i got 1 ~ 8 ms


@Mordo i didn’t made anything i just use the configuration file (ecosystem.json) and start the process using “pm2 start ecosystem.json”