Leaflet does not run at glitch.com


#1

Hi,
when I try to run the map library, leaflet, the following error message is output in the console:
ReferenceError: window is not defined at leaflet-src.js:230.86.
I tried to run the npm package, ‘leaflet’, at RunKit. There also a similar error message was output:
Reference Eroor: Window is not defined.
Fix: use global instead of win dow. Run Kit is a node environment. so window and other browser features won’t exist. If you are trying to access the global object, you can simply use global in\stead.

Is there a way to edit the npm package to make these changes and then use it? Can I do it or can the administrators of glitch.com do it? any help is appreciated.
The app(or my program) is called nightlife11. I am trying to do the freecode camp backend challenge, “nightlife voting”. Thank you
Ahammadunny Pathiaseril.
ahammadunny@hotmail.com


#2

I think the best thing to do is post an issue on the Leaflet github page https://github.com/Leaflet/Leaflet