Libsecret-1-dev question


New to glitch and trying to install an NPM package through pnpm. When I tried to install it, it looks like it requires libsecret-1 / libsecret-1-dev to use with Keytar.

The package is @servicenow/cli

Any help or guidance would be greatly appreciated.


Hey @MBahrSNC, welcome to Glitch!

I’ve tried installing @servicenow/cli using pnpm on a random project of mine, and it did work… I’ve use command pnpm install @servicenow/cli on my console, have you done it another way? I do not know what this package does so I might not be qualified to answer your question…

Hope this helps,

Hi @milo,

Thanks for the quick response. I created a new project using hello-express and then did the pnpm command. To verify it installed correctly, i typed in now-cli --version and it gives me an error with keytar and libsecret.

I do as well get the same error, have you tried installing it locally on your computer before?

Yeah I was able to install it locally and confirmed it’s working.

When I run now-cli —version it outputs 17.0.0