Logs keep saying "Resolving"

It keeps saying “Resolving: total 521, reused 521, downloaded 0” in logs

I don’t want to remix my project because it’s private. (can’t remix tho) :confused:

Can anyone help me?

I tried to update quick.db so it started to show error so i wanted to return back, one thing led to another.

Is there a way to fix it with terminal? What do i need to enter?

I think there’s nothing you need to do

It doesn’t finish, i want to cancel it even if i force it, that’s why i open this thread

Try clicking “:bomb: Clear” or selecting “Debugger” to see what it says

this looks like either:

  1. the package manager is broken; or
  2. the project’s start script or install script runs refresh

package manager broken

to diagnose:
run the npm/pnpm install (whichever one you have configured) command with more verbose logging

to resolve:
not sure, but probably try the other one of npm or pnpm.
depends on what the more verbose logging says, really

script runs refresh

to diagnose:
edit your package.json to have empty install script and "true" start script.
if the behavior no longer occurs, that’s consistent with this being the problem

to resolve:
somehow rewrite things not to run refresh

5 Likes

Thx, i’ll try these.

Still same. ._.

Hi @Kyoya! Please don’t bump old posts, that makes them go to the top of the list! :slight_smile:
Try running refresh with the terminal

Are you sure this is an error? :thinking:
Try clicking “Clear” on the logs section

Are you sure you know something about this?

Ha, not sure! :rofl: But it doesn’t look like an error to me. Can you please share a full screen of your editor?
You can always redact code, of course

I did enter “enable-pnpm” and “npm cache clean --force” etc… in Terminal then these are popped up.

ERROR ENOENT: no such file or directory, chmod ‘/rbd/pnpm-volume/6ea8fd9a-ae02-47d5-ab82-dd55d2089001/node_modules/node/bin/node’

I tried refresh, doesn’t effect.

Can you please share a screenshot of your code?

Because else we can’t find what’s wrong :grin:

… node_modules/node/bin/node

what method are you using to get the nodejs version that you use? would you be able to switch to the engines.node field in package.json?

1 Like

Try upgrading your node to 16.x :grin:

it become worse, project got suspended then i got it back with half of package.json.

Oh bad… Probabily support@glitch.com can help you

Or you can try rewinding your project